Author Topic: Eroare dupa update nr 1364  (Read 287 times)

zbask

  • Newbie
  • *
  • Posts: 10
    • View Profile
Eroare dupa update nr 1364
« on: March 01, 2023, 06:39:24 PM »
buna, dupa un update pe server linux si incercare esuata de a updata baza de date primesc aceasta eroare context 1364, am facut update si la aplicatia de pe windows


Serghei

  • Administrator
  • Hero Member
  • *****
  • Posts: 1439
    • View Profile
Re: Eroare dupa update nr 1364
« Reply #1 on: March 01, 2023, 06:51:02 PM »
Probabil nu ati actualizat serverul de baze de date.

zbask

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Eroare dupa update nr 1364
« Reply #2 on: March 01, 2023, 07:03:11 PM »
da asa este nu am updatat am descarcat ultimul deb si dupa instalare imi da aceste erori

dpkg -i icefact_1.3.0.4-1_amd64.deb
Selecting previously unselected package icefact.
(Reading database ... 146342 files and directories currently installed.)
Preparing to unpack icefact_1.3.0.4-1_amd64.deb ...
Unpacking icefact (1.3.0.4-1) ...
dpkg: dependency problems prevent configuration of icefact:
 icefact depends on libc6 (>= 2.29); however:
  Version of libc6:amd64 on system is 2.27-3ubuntu1.6.
 icefact depends on libfreetype6 (>= 2.9.1); however:
  Version of libfreetype6:amd64 on system is 2.8.1-2ubuntu2.2.
 icefact depends on libgcc-s1 (>= 3.4); however:
  Package libgcc-s1 is not installed.

dpkg: error processing package icefact (--install):
 dependency problems - leaving unconfigured
Processing triggers for mime-support (3.60ubuntu1) ...
Errors were encountered while processing:
 icefact


am dat si comanda

wget http://icesoft.ro/download/icefact-1.3.4-linux-i686.run

sudo chmod 755 icefact-1.3.4-linux-i686.run



./icefact-1.3.4-linux-i686.run
./icefact-1.3.4-linux-i686.run: line 1: syntax error near unexpected token `newline'
./icefact-1.3.4-linux-i686.run: line 1: `<!DOCTYPE html>'

Serghei

  • Administrator
  • Hero Member
  • *****
  • Posts: 1439
    • View Profile
Re: Eroare dupa update nr 1364
« Reply #3 on: March 01, 2023, 07:12:24 PM »
Ultima versiune de IceFact Server o gasiti aici: https://icesoft.ro/icefact-server

zbask

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Eroare dupa update nr 1364
« Reply #4 on: March 01, 2023, 07:32:58 PM »
incerc sa il reinstalez sau sa instalez si imi da ca ar trebui sa reinstalez packetul primesc aceasta eroare

root@gln:/home/bask# apt --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  icefact-srv
0 upgraded, 0 newly installed, 1 to remove and 90 not upgraded.
1 not fully installed or removed.
After this operation, 1,260 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 146330 files and directories currently installed.)
Removing icefact-srv (0.9.4-1) ...
Failed to disable unit: Unit file icefactd.service does not exist.
dpkg: error processing package icefact-srv (--remove):
 installed icefact-srv package post-removal script subprocess returned error exit status 1
Errors were encountered while processing:
 icefact-srv
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@gln:/home/bask#

zbask

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Eroare dupa update nr 1364
« Reply #5 on: March 01, 2023, 07:37:45 PM »
root@gln:/home/bask# apt remove -f icefact-srv
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  icefact-srv
0 upgraded, 0 newly installed, 1 to remove and 90 not upgraded.
1 not fully installed or removed.
After this operation, 1,260 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 146330 files and directories currently installed.)
Removing icefact-srv (0.9.4-1) ...
Failed to disable unit: Unit file icefactd.service does not exist.
dpkg: error processing package icefact-srv (--remove):
 installed icefact-srv package post-removal script subprocess returned error exit status 1
Errors were encountered while processing:
 icefact-srv
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@gln:/home/bask#

incerc asa si nu ma lasa sa dezinstalez packetul

Serghei

  • Administrator
  • Hero Member
  • *****
  • Posts: 1439
    • View Profile
Re: Eroare dupa update nr 1364
« Reply #6 on: March 01, 2023, 07:38:49 PM »
Încercați în prima fază sa dezinstalați versiunea veche, pentru că s-a trecut de la SysV la systemd și script-urile de start/stop nu prea se mai pupă. Și asigurați-vă că aveți un distro suficient de nou (v0.9.4 este compilată pe Focal Fossa).

zbask

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Eroare dupa update nr 1364
« Reply #7 on: March 02, 2023, 04:12:50 AM »
am reusit sa dezinstalez dar nu imi este compatibil sistemul, o versiune mai veche de pachet deb nu as gasi?

Serghei

  • Administrator
  • Hero Member
  • *****
  • Posts: 1439
    • View Profile
Re: Eroare dupa update nr 1364
« Reply #8 on: March 02, 2023, 11:49:00 AM »
Nu vă ajută o versiune veche, pentru că nu va funcționa cu ultima versiune de IceFact.

zbask

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Eroare dupa update nr 1364
« Reply #9 on: March 02, 2023, 07:44:52 PM »
am inteles trebuie sa fac upgrade la distro,

dpkg -i icefact-srv_0.9.4-1_amd64.deb
Selecting previously unselected package icefact-srv.
(Reading database ... 182032 files and directories currently installed.)
Preparing to unpack icefact-srv_0.9.4-1_amd64.deb ...
Unpacking icefact-srv (0.9.4-1) ...
dpkg: dependency problems prevent configuration of icefact-srv:
 icefact-srv depends on libc6 (>= 2.29); however:
  Version of libc6:amd64 on system is 2.27-3ubuntu1.6.

dpkg: error processing package icefact-srv (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 icefact-srv

primesc aceasta eroare dar nu as face upgrade la sistem si nu pot upgrada libc6 este o optiune sa dau instalare fortata?

Serghei

  • Administrator
  • Hero Member
  • *****
  • Posts: 1439
    • View Profile
Re: Eroare dupa update nr 1364
« Reply #10 on: March 02, 2023, 07:50:04 PM »
Da, trebuie făcut upgrade la distro. O instalare forțată când dependența este chiar glibc cel mai probabil nu va funcționa.

Să mențin compabilitatea cu distro-uri atât de vechi este un efort pare mare, până și Focal Fossa este din 2020, deja și asta este destul de aproape de end-of-life.