Author Topic: Ubuntu 17.04 si libpng  (Read 278 times)

icmono

  • Newbie
  • *
  • Posts: 1
    • View Profile
Ubuntu 17.04 si libpng
« on: June 15, 2017, 02:14:20 PM »
Salut,

Pentru cei care intampina urmatoarea problema la instalare pe *ubuntu 17.04:

Code: [Select]
icmono@icmhq:~/Downloads$ sudo dpkg -i icefact_1.1.116-1_amd64.deb
Selecting previously unselected package icefact.
(Reading database ... 211915 files and directories currently installed.)
Preparing to unpack icefact_1.1.116-1_amd64.deb ...
Unpacking icefact (1.1.116-1) ...
dpkg: dependency problems prevent configuration of icefact:
 icefact depends on libpng12-0 (>= 1.2.13-4); however:
  Package libpng12-0 is not installed.

dpkg: error processing package icefact (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.13.3-6ubuntu5) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu2) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.15-1) ...
Errors were encountered while processing:
 icefact

Nu va pierdeti timpul cu installarea libpng din repo.
libpng16-16 este singura versiune disponibila in repo.

Rezolvare:

Code: [Select]
wget ftp://ftp.lug.ro/ubuntu/pool/main/libp/libpng/libpng12-0_1.2.54-1ubuntu1_amd64.deb
sudo dpkg -i libpng12-0_1.2.54-1ubuntu1_amd64.deb
sudo dpkg -i icefact_1.1.116-1_amd64.deb



Serghei

  • Administrator
  • Hero Member
  • *****
  • Posts: 852
    • View Profile
Re: Ubuntu 17.04 si libpng
« Reply #1 on: June 15, 2017, 02:35:48 PM »
Interesant. La urmatoarea versiune voi "embedda" libpng direct in aplicatie, ca sa nu mai apar tipul asta de probleme.